Configuration

Q4EN

What is the minimum configuration required to use SafeSky?

SafeSky is iOS and Android compatible, and works on smartphones and tablets.
- For Apple users, iPhone or iPad should have at least iOS 13 update to run SafeSky.
- For Android users, it will require at least an Android phone or tablet version 7 Nougat and 1.5GB RAM.